Audience View System Slow down.

Incident Report for AudienceView Professional

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 09:24 EST

Investigating

We have identified a slowdown within the Audience View Professional system. We are investigating, and we thank you for your patience.
Posted Feb 24, 2026 - 22:41 EST
This incident affected: Sell and Sell+, Client Home, Consumer Interface, Payment Processing, Series Management, Reporting, Communications, Order Management, and Learning Portal.