Maintenance is completed and we are verifying the updates.
Posted Jun 27, 2025 - 12:41 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2025 - 12:00 EDT
Scheduled
Due to urgent, vital security updates, AudienceView Professional will be inaccessible at noon EST today. We expect both the admin site and the consumer interface to be down, and the downtime should last around 10 minutes. This is essential maintenance for the safety of you and your patrons, and we at AudienceView take that extremely seriously. Thank you for your patience and understanding while we complete this necessary work.
Posted Jun 27, 2025 - 11:25 EDT
This scheduled maintenance affected: Sell and Sell+, Client Home, Consumer Interface, Payment Processing, Series Management, Reporting, Communications, Order Management, and Learning Portal.