Statement History page inaccessible

Incident Report for AudienceView Professional

Resolved

This incident has been resolved
Posted Jun 20, 2022 - 18:48 EDT

Update

A fix has been implemented and we are currently monitoring
Posted Jun 20, 2022 - 16:26 EDT

Monitoring

A fix has been implemneted and we are currently monitoring
Posted Jun 20, 2022 - 16:24 EDT

Investigating

Some clients are encountering a Page Processing Error when attempting to view their Statement History page (Reports > Statement History).
We are aware of the issue and are actively investigating this now. We will update this page with our progress.
Posted Jun 20, 2022 - 10:54 EDT
This incident affected: Reporting.