Intermittent Payment Processing Slowness and Timeouts

Incident Report for AudienceView Professional

Update

Our Engineering team is continuing to actively investigate the intermittent timeout issues affecting payment processing and patron record searches. While the issue remains under investigation, it continues to be treated as a high priority. Thank you for your patience and understanding.
Posted Jul 06, 2026 - 11:28 EDT

Investigating

We are investigating intermittent timeout issues affecting payment processing and patron record searches for multiple clients. Users may experience delays or timeout errors when submitting transactions. Our Engineering team is actively investigating and monitoring the situation.

We appreciate your patience and understanding while we work to resolve this issue.
Posted Jul 05, 2026 - 14:32 EDT
This incident affects: Sell and Sell+ and Payment Processing.