Error processing payments in QuickSell+

Incident Report for AudienceView Professional

Resolved

This incident has been resolved.
Posted Jul 20, 2023 - 15:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2023 - 11:38 EDT

Investigating

We are experiencing errors completing orders in QuickSell+. We are currently investigating this issue.
Posted Jul 20, 2023 - 11:05 EDT
This incident affected: Quicksell+.