Upcoming Scheduled Maintenance Notice

Incident Report for AudienceView Professional

Resolved

The maintenance window is complete.
Posted Jun 15, 2026 - 09:14 EDT

Investigating

We’ll be performing vital system maintenance on Monday, June 15 at 3:00 AM EST. We expect approximately 30 minutes of downtime. Thank you for your patience and understanding while we complete this necessary work.
Posted Jun 12, 2026 - 17:22 EDT
This incident affected: Sell and Sell+, Client Home, Consumer Interface, Payment Processing, Series Management, Reporting, Communications, Order Management, and Learning Portal.