Credit Card Payment Processing Outage

Incident Report for AudienceView Professional

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 15:53 EDT

Monitoring

A fix for the credit card payment processing issue has been implemented and we are monitoring the results.
Posted Jun 16, 2025 - 14:52 EDT

Investigating

We have been made aware of an issue with processing credit card payments on AudienceView Professional. You may see a number of reported error messages associated with this outage.

We are investigating this issue and hope to have an update shortly.
Posted Jun 16, 2025 - 14:00 EDT
This incident affected: Sell and Sell+ and Consumer Interface.